SIGER Maintenance
Incident Report for eFirma.com
Resolved
SIGER has finished maintenance
Posted Aug 31, 2020 - 16:06 CDT
Identified
The SIGER (Sistema Integral de Gestión Registral) is under maintenance, this has reduced the ability to verify Incorporation Letters on our end. Service will come back to normal when their maintenance is done.
Posted Aug 31, 2020 - 14:04 CDT
This incident affected: KYC (Identity Data Fetch).