Infrastructure maintenance
Incident Report for eFirma.com
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 20:45 CST
Update
We are currently working on fixing this issue.
Posted Oct 30, 2019 - 15:14 CST
Update
We are continuing to work on a fix for this issue.
Posted Oct 30, 2019 - 15:10 CST
Identified
Our infrastructure is being reconfigured.
Posted Oct 29, 2019 - 21:52 CST
This incident affected: eSignatures (TimeStamping Servers, OCSP), KYC (Identity Data Fetch, Sanctions), and API.