Server under maintenance
Incident Report for eFirma.com
Resolved
This incident has been resolved.
Posted Feb 19, 2022 - 03:30 CST
Monitoring
Maintenance finished under schedule window, expected delay to resolve while new DNS propagation happens.
Posted Feb 19, 2022 - 01:55 CST
Identified
We are under scheduled maintenance of our infrastructure.
Posted Feb 18, 2022 - 22:04 CST
This incident affected: eSignatures (OCSP, TimeStamping Servers), KYC (Identity Data Fetch, Sanctions), and API.